Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

avast! Multiple Vulnerabilities - Oct09 (Windows)

Information

Severity

Severity

High

Family

Family

Buffer overflow

CVSSv2 Base

CVSSv2 Base

7.2

CVSSv2 Vector

CVSSv2 Vector

AV:L/AC:L/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

12 years ago

Modified

Modified

3 years ago

Summary

This host is installed with avast! AntiVirus and is prone to multiple vulnerabilities.

Insight

Insight

- A boundary error exists in the 'aswMon2' kernel driver when processing IOCTLs. This can be exploited to cause a stack-based buffer overflow via a specially crafted 0xB2C80018 IOCTL. - An error in the 'AavmKer4.sys' kernel driver that can be exploited to corrupt memory via a specially crafted 0xB2D6000C or 0xB2D60034 IOCTL. - An unspecified error exists in the ashWsFtr.dll library which can be exploited to cause unknown impact.

Affected Software

Affected Software

avast! Home and Professional version prior to 4.8.1356 on Windows.

Solution

Solution

Upgrade to avast! version 4.8.1356 or later.

Common Vulnerabilities and Exposures (CVE)