Free vulnerability management software

Mageni is a free, open-source, and powerful vulnerability management platform that takes the pain out of cybersecurity and vulnerability management.

Download Now
App screenshot

CentOS Update for libsmbclient CESA-2014:0867 centos7

Information

Severity

Severity

Low

Family

Family

CentOS Local Security Checks

CVSSv2 Base

CVSSv2 Base

3.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:S/C:P/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

7 years ago

Modified

Modified

3 years ago

Summary

The remote host is missing an update for the 'libsmbclient' package(s) announced via the referenced advisory.

Insight

Insight

Samba is an open-source implementation of the Server Message Block (SMB) or Common Internet File System (CIFS) protocol, which allows PC-compatible machines to share files, printers, and other information. A denial of service flaw was found in the way the sys_recvfile() function of nmbd, the NetBIOS message block daemon, processed non-blocking sockets. An attacker could send a specially crafted packet that, when processed, would cause nmbd to enter an infinite loop and consume an excessive amount of CPU time. (CVE-2014-0244) A flaw was found in the way Samba created responses for certain authenticated client requests when a shadow-copy VFS module was enabled. An attacker able to send an authenticated request could use this flaw to disclose limited portions of memory per each request. (CVE-2014-0178) It was discovered that smbd, the Samba file server daemon, did not properly handle certain files that were stored on the disk and used a valid Unicode character in the file name. An attacker able to send an authenticated non-Unicode request that attempted to read such a file could cause smbd to crash. (CVE-2014-3493) Red Hat would like to thank Daniel Berteaud of FIREWALL-SERVICES SARL for reporting CVE-2014-0244, and the Samba project for reporting CVE-2014-0178 and CVE-2014-3493. The Samba project acknowledges Christof Schmitt as the original reporter of CVE-2014-0178, and Simon Arlott as the original reporter of CVE-2014-3493. All Samba users are advised to upgrade to these updated packages, which contain backported patches to correct these issues. After installing this update, the smb service will be restarted automatically.

Affected Software

Affected Software

libsmbclient on CentOS 7

Solution

Solution

Please install the updated packages.

Common Vulnerabilities and Exposures (CVE)

Ease with a few clicks your vulnerability scanning, assessment and management process

Mageni is a free and open-source vulnerability management software. Download it now.

1. Download Multipass

sudo snap install multipass

2. Launch a multipass instance

multipass launch -c 2 -m 6G -d 20G -n mageni 20.04 && multipass shell mageni

3. Install Mageni

curl -sL https://www.mageni.net/installation | sudo bash

1. If you don’t have it already, install Brew. Then, to install Multipass simply execute:

brew install --cask multipass

2. Launch a multipass instance

multipass launch -c 2 -m 6G -d 20G -n mageni 20.04 && multipass shell mageni

2. Install Mageni

curl -sL https://www.mageni.net/installation | sudo bash

1. Download the installer for Windows

Note: You need Windows 10 Pro/Enterprise/Education v 1803 or later, or any Windows 10 with VirtualBox

2. Ensure your network is private

Make sure your local network is designated as private, otherwise Windows prevents Multipass from starting.

3. Run the installer

You need to allow the installer to gain Administrator privileges.

4. Launch a multipass instance

multipass launch -c 2 -m 6G -d 20G -n mageni 20.04

5. Log into the multipass instance

multipass shell mageni

6. Install Mageni

curl -sL https://www.mageni.net/installation | sudo bash