Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CesarFTP MKD Command Buffer Overflow

Information

Severity

Severity

High

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Wont Fix

Created

Created

14 years ago

Modified

Modified

3 years ago

Summary

The remote system is running CesarFTP server, which is vulnerable to a buffer overflow attack when using some ftp command followed with a long string of arguments.

Insight

Insight

Note that the service runs with LOCAL SYSTEM privileges on the remote host, which means that an attacker can possible gain complete control over the system. To use the flaw an attacker needs access to the requested FTP server, by using a valid account/password or if activated the anonymous account.

Affected Software

Affected Software

CesarFTP Server version <= 0.99g

Solution

Solution

No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Common Vulnerabilities and Exposures (CVE)