Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Cisco NX-OS Software HSRP Authentication Denial of Service Vulnerability

Information

Severity

Severity

Medium

Family

Family

CISCO

CVSSv2 Base

CVSSv2 Base

4.8

CVSSv2 Vector

CVSSv2 Vector

AV:A/AC:L/Au:N/C:N/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

6 years ago

Modified

Modified

3 years ago

Summary

A vulnerability in Hot Standby Router Protocol (HSRP) authentication in the Cisco Nexus series could allow an unauthenticated, adjacent attacker to affect the state of HSRP group members and cause black holing of traffic. The vulnerability is due to incorrect parsing of malformed HSRP packets. An attacker could exploit this vulnerability by sending malformed HSRP packets to bypass HSRP authentication. An exploit could allow the attacker to bypass HSRP authentication and affect the state of active HSRP group members, causing them to go to SPEAK state, which leads to black holing of traffic and causes a denial of service (DoS) condition. Cisco has confirmed the vulnerability in a security notice. However, software updates are not available. Although an attacker does not need to authenticate to a targeted device to exploit this vulnerability, the attacker must be on the same collision or broadcast domain of the targeted device. This access requirement may reduce the likelihood of a successful exploit. Cisco indicates through the CVSS score that functional exploit code exists. However, the code is not known to be publicly available.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

See the referenced vendor advisory for a solution.

Common Vulnerabilities and Exposures (CVE)