Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Cyrus IMAP Server SIEVE Script Handling Buffer Overflow Vulnerability

Information

Severity

Severity

Medium

Family

Family

Buffer overflow

CVSSv2 Base

CVSSv2 Base

4.4

CVSSv2 Vector

CVSSv2 Vector

AV:L/AC:M/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

12 years ago

Modified

Modified

3 years ago

Summary

This host is running Cyrus IMAP Server and is prone to buffer overflow vulnerability.

Insight

Insight

The flaw is caused is due to error in the handling of 'SIEVE' Script, that fails to perform adequate boundary checks on user-supplied data.

Affected Software

Affected Software

Cyrus IMAP Server versions 2.3.14 and prior.

Solution

Solution

Apply the patches from the references or upgrade to the latest version.

Common Vulnerabilities and Exposures (CVE)