cyrus-imsp abook_dbname buffer overflow

Published: 2005-11-03 13:08:04

CVSS Base Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Recommendations:
Upgrade cyrus-imsp server to version version 1.6a4 or 1.7a.

Summary:
The remote host is running a version of cyrus-imsp (Internet Message Support Protocol) which has a buffer overflow bug.

Impact:
An attacker could exploit this bug to execute arbitrary code on this system with the privileges of the root user.

Technical Details:
The overflow occurs when the user issues a too long argument as his name, causing an overflow in the abook_dbname function command.

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/9227

Search
Severity
Medium
CVSS Score
6.8

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.