Debian LTS Advisory ([SECURITY] [DLA 1137-1] db4.7 security update)

Published: 2018-02-06 23:00:00
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:L/AC:L/Au:N/C:P/I:P/A:P

Solution Type:
Vendor Patch

Detection Type:
Linux Distribution Package

Affected Versions:
db4.7 on Debian Linux

Recommendations:
For Debian 7 'Wheezy', these problems have been fixed in version 4.7.25-21+deb7u1. We recommend that you upgrade your db4.7 Linux Distribution Packages.

Summary:
It was found that the Berkeley DB reads DB_CONFIG from the current working directory, leading to information leak by tricking privileged processes into reading arbitrary files.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2017-10140

CVE Analysis

https://www.mageni.net/cve/CVE-2017-10140

References:

https://lists.debian.org/debian-lts-announce/2017/10/msg00015.html

Severity
Medium
CVSS Score
4.6
Published
2018-02-06
Modified
2019-03-18
Category
Debian Local Security Checks

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.