Free vulnerability management software

Mageni is a free, open-source, and powerful vulnerability management platform that takes the pain out of cybersecurity and vulnerability management.

Download Now
App screenshot

Debian LTS Advisory ([SECURITY] [DLA 1562-1] poppler security update)

Information

Severity

Severity

Medium

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

4.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

3 years ago

Modified

Modified

3 years ago

Summary

Various security issues were discovered in the poppler PDF rendering shared library. CVE-2017-18267 The FoFiType1C::cvtGlyph function in fofi/FoFiType1C.cc in Poppler through 0.64.0 allows remote attackers to cause a denial of service (infinite recursion) via a crafted PDF file, as demonstrated by pdftops. The applied fix in FoFiType1C::cvtGlyph prevents infinite recursion on such malformed documents. CVE-2018-10768 A NULL pointer dereference in the AnnotPath::getCoordsLength function in Annot.h in Poppler 0.24.5 had been discovered. A crafted input will lead to a remote denial of service attack. Later versions of Poppler such as 0.41.0 are not affected. The applied patch fixes the crash on AnnotInk::draw for malformed documents. CVE-2018-13988 Poppler through 0.62 contains an out of bounds read vulnerability due to an incorrect memory access that is not mapped in its memory space, as demonstrated by pdfunite. This can result in memory corruption and denial of service. This may be exploitable when a victim opens a specially crafted PDF file. The applied patch fixes crashes when Object has negative number. (Specs say, number has to be > 0 and gen >= 0). For Poppler in Debian jessie, the original upstream patch has been backported to Poppler's old Object API. CVE-2018-16646 In Poppler 0.68.0, the Parser::getObj() function in Parser.cc may cause infinite recursion via a crafted file. A remote attacker can leverage this for a DoS attack. A range of upstream patches has been applied to Poppler's XRef.cc in Debian jessie to consolidate a fix for this issue.

Affected Software

Affected Software

poppler on Debian Linux

Detection Method

Detection Method

This check tests the installed software version using the apt package manager.

Solution

Solution

For Debian 8 'Jessie', these problems have been fixed in version 0.26.5-2+deb8u5. We recommend that you upgrade your poppler packages.

Common Vulnerabilities and Exposures (CVE)

Ease with a few clicks your vulnerability scanning, assessment and management process

Mageni is a free and open-source vulnerability management software. Download it now.

1. Download Multipass

sudo snap install multipass

2. Launch a multipass instance

multipass launch -c 2 -m 6G -d 20G -n mageni 20.04 && multipass shell mageni

3. Install Mageni

curl -sL https://www.mageni.net/installation | sudo bash

1. If you don’t have it already, install Brew. Then, to install Multipass simply execute:

brew install --cask multipass

2. Launch a multipass instance

multipass launch -c 2 -m 6G -d 20G -n mageni 20.04 && multipass shell mageni

2. Install Mageni

curl -sL https://www.mageni.net/installation | sudo bash

1. Download the installer for Windows

Note: You need Windows 10 Pro/Enterprise/Education v 1803 or later, or any Windows 10 with VirtualBox

2. Ensure your network is private

Make sure your local network is designated as private, otherwise Windows prevents Multipass from starting.

3. Run the installer

You need to allow the installer to gain Administrator privileges.

4. Launch a multipass instance

multipass launch -c 2 -m 6G -d 20G -n mageni 20.04

5. Log into the multipass instance

multipass shell mageni

6. Install Mageni

curl -sL https://www.mageni.net/installation | sudo bash