Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian LTS Advisory ([SECURITY] [DLA 1672-1] curl security update)

Information

Severity

Severity

High

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

3 years ago

Modified

Modified

3 years ago

Summary

It was discovered that there were three vulnerabilities in the curl command-line HTTP (etc.) client: * CVE-2018-16890: A heap buffer out-of-bounds read vulnerability in the handling of NTLM type-2 messages. * CVE-2019-3822: Stack-based buffer overflow in the handling of outgoing NTLM type-3 headers. * CVE-2019-3823: Heap out-of-bounds read in code handling the end of a response in the SMTP protocol.

Affected Software

Affected Software

curl on Debian Linux

Detection Method

Detection Method

This check tests the installed software version using the apt package manager.

Solution

Solution

For Debian 8 'Jessie', this issue has been fixed in curl version 7.38.0-4+deb8u14. We recommend that you upgrade your curl packages.

Common Vulnerabilities and Exposures (CVE)