Debian Security Advisory DSA 1892-1 (dovecot)

Published: 2009-09-28 17:09:13
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Recommendations:
https://secure1.securityspace.com/smysecure/catid.html?in=DSA%201892-1

Technical Details:
It was discovered that the SIEVE component of dovecot, a mail server that supports mbox and maildir mailboxes, is vulnerable to a buffer overflow when processing SIEVE scripts. This can be used to elevate privileges to the dovecot system user. An attacker who is able to install SIEVE scripts executed by the server is therefore able to read and modify arbitrary email messages on the system. For the oldstable distribution (etch), this problem has been fixed in version 1.0.rc15-2etch5. For the stable distribution (lenny), this problem has been fixed in version 1:1.0.15-2.3+lenny1. For the testing distribution (squeeze) and the unstable distribution (sid), this problem has been fixed in version 1:1.2.1-1. We recommend that you upgrade your dovecot Linux Distribution Packages.

Summary:
The remote host is missing an update to dovecot announced via advisory DSA 1892-1.

Detection Type:
Linux Distribution Package

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2009-2632
https://nvd.nist.gov/vuln/detail/CVE-2009-3235

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.