Debian Security Advisory DSA 2076-1 (gnupg2)

Published: 2010-08-21 06:54:16
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:H/Au:N/C:P/I:P/A:P

Recommendations:
https://secure1.securityspace.com/smysecure/catid.html?in=DSA%202076-1

Technical Details:
It was discovered that GnuPG 2 uses a freed pointer when verify a signature or importing a certificate with many Subject Alternate Names, potentially leading to arbitrary code execution. For the stable distribution (lenny), this problem has been fixed in version 2.0.9-3.1+lenny1. For the unstable distribution (sid), this problem has been fixed in version 2.0.14-2. GnuPG 1 (in the gnupg Linux Distribution Package) is not affected by this problem. We recommend that you upgrade your gnupg2 Linux Distribution Packages.

Summary:
The remote host is missing an update to gnupg2 announced via advisory DSA 2076-1.

Detection Type:
Linux Distribution Package

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2010-2547

Search
Severity
Medium
CVSS Score
5.1

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.