Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 2085-1 (lftp)

Information

Severity

Severity

High

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

12 years ago

Modified

Modified

4 years ago

Summary

The remote host is missing an update to lftp announced via advisory DSA 2085-1.

Insight

Insight

It was discovered that in lftp, a command-line HTTP/FTP client, there is no proper validation of the filename provided by the server through the Content-Disposition header attackers can use this flaw by suggesting a filename they wish to overwrite on the client machine, and then possibly execute arbitrary code (for instance if the attacker elects to write a dotfile in a home directory). For the stable distribution (lenny), this problem has been fixed in version 3.7.3-1+lenny1. For the testing distribution (squeeze), this problem has been fixed in version 4.0.6-1. For the unstable distribution (sid), this problem has been fixed in version 4.0.6-1. We recommend that you upgrade your lftp packages.

Solution

Solution

https://secure1.securityspace.com/smysecure/catid.html?in=DSA%202085-1

Common Vulnerabilities and Exposures (CVE)