Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 2198-1 (tex-common)

Information

Severity

Severity

Medium

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

6.8

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

11 years ago

Modified

Modified

8 months ago

Summary

The remote host is missing an update to tex-common announced via advisory DSA 2198-1.

Insight

Insight

Mathias Svensson discovered that tex-common, a package shipping a number of scripts and configuration files necessary for TeX, contains insecure settings for the shell_escape_commands directive. Depending on the scenario, this may result in arbitrary code execution when a victim is tricked into processing a malicious tex-file or this is done in an automated fashion. The oldstable distribution (lenny) is not affected by this problem due to shell_escape being disabled. For the stable distribution (squeeze), this problem has been fixed in version 2.08.1. For the testing (wheezy) and unstable (sid) distributions, this problem will be fixed soon.

Solution

Solution

We recommend that you upgrade your tex-common packages.

Common Vulnerabilities and Exposures (CVE)