Debian Security Advisory DSA 2864-1 (postgresql-8.4 - several vulnerabilities)

Published: 2014-02-19 23:00:00
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:S/C:P/I:P/A:P

Affected Versions:
postgresql-8.4 on Debian Linux

Recommendations:
For the oldstable distribution (squeeze), these problems have been fixed in version 8.4.20-0squeeze1. For the unstable distribution (sid), these problems have been fixed in version 9.3.3-1 of the postgresql-9.3 Linux Distribution Package. We recommend that you upgrade your postgresql-8.4 Linux Distribution Packages.

Summary:
Various vulnerabilities were discovered in PostgreSQL: CVE-2014-0060 Shore up GRANT ... WITH ADMIN OPTION restrictions (Noah Misch) Granting a role without ADMIN OPTION is supposed to prevent the grantee from adding or removing members from the granted role, but this restriction was easily bypassed by doing SET ROLE first. The security impact is mostly that a role member can revoke the access of others, contrary to the wishes of his grantor. Unapproved role member additions are a lesser concern, since an uncooperative role member could provide most of his rights to others anyway by creating views or SECURITY DEFINER functions. Description truncated. Please see the references for more information.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

Detection Type:
Linux Distribution Package

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2014-0060
https://nvd.nist.gov/vuln/detail/CVE-2014-0061
https://nvd.nist.gov/vuln/detail/CVE-2014-0062
https://nvd.nist.gov/vuln/detail/CVE-2014-0063
https://nvd.nist.gov/vuln/detail/CVE-2014-0064
https://nvd.nist.gov/vuln/detail/CVE-2014-0065
https://nvd.nist.gov/vuln/detail/CVE-2014-0066
https://nvd.nist.gov/vuln/detail/CVE-2014-0067

References:

http://www.debian.org/security/2014/dsa-2864.html

Search
Severity
Medium
CVSS Score
6.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.