Debian Security Advisory DSA 3090-1 (iceweasel - security update)

Published: 2014-12-03 23:00:00
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:M/Au:N/C:P/I:P/A:P

Solution Type:
Vendor Patch

Affected Versions:
iceweasel on Debian Linux

Recommendations:
For the stable distribution (wheezy), these problems have been fixed in version 31.3.0esr-1~deb7u1. For the upcoming stable distribution (jessie), these problems will be fixed soon. For the unstable distribution (sid), these problems have been fixed in version 31.3.0esr-1. We recommend that you upgrade your iceweasel Linux Distribution Packages.

Summary:
Multiple security issues have been found in Iceweasel, Debian's version of the Mozilla Firefox web browser: Multiple memory safety errors, buffer overflows, use-after-frees and other implementation errors may lead to the execution of arbitrary code, the bypass of security restrictions or denial of service.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

Detection Type:
Linux Distribution Package

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2014-1587
https://nvd.nist.gov/vuln/detail/CVE-2014-1590
https://nvd.nist.gov/vuln/detail/CVE-2014-1592
https://nvd.nist.gov/vuln/detail/CVE-2014-1593
https://nvd.nist.gov/vuln/detail/CVE-2014-1594

References:

http://www.debian.org/security/2014/dsa-3090.html

Search
Severity
Medium
CVSS Score
6.8

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.