Debian Security Advisory DSA 3103-1 (libyaml-libyaml-perl - security update)

Published: 2014-12-12 23:00:00
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:P

Solution Type:
Vendor Patch

Affected Versions:
libyaml-libyaml-perl on Debian Linux

Recommendations:
For the stable distribution (wheezy), this problem has been fixed in version 0.38-3+deb7u3. For the upcoming stable distribution (jessie), this problem has been fixed in version 0.41-6. For the unstable distribution (sid), this problem has been fixed in version 0.41-6. We recommend that you upgrade your libyaml-libyaml-perl Linux Distribution Packages.

Summary:
Jonathan Gray and Stanislaw Pitucha found an assertion failure in the way wrapped strings are parsed in LibYAML, a fast YAML 1.1 parser and emitter library. An attacker able to load specially crafted YAML input into an application using libyaml could cause the application to crash. This update corrects this flaw in the copy that is embedded in the libyaml-libyaml-perl Linux Distribution Package.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

Detection Type:
Linux Distribution Package

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2014-9130

References:

http://www.debian.org/security/2014/dsa-3103.html

Search
Severity
Medium
CVSS Score
5.0

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.