Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 3243-1 (libxml-libxml-perl - security update)

Information

Severity

Severity

Medium

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

7 years ago

Modified

Modified

8 months ago

Summary

Tilmann Haak from xing.com discovered that XML::LibXML, a Perl interface to the libxml2 library, did not respect the expand_entities parameter to disable processing of external entities in some circumstances. This may allow attackers to gain read access to otherwise protected resources, depending on how the library is used.

Affected Software

Affected Software

libxml-libxml-perl on Debian Linux

Detection Method

Detection Method

This check tests the installed software version using the apt package manager.

Solution

Solution

For the oldstable distribution (wheezy), this problem has been fixed in version 2.0001+dfsg-1+deb7u1. For the stable distribution (jessie), this problem has been fixed in version 2.0116+dfsg-1+deb8u1. For the unstable distribution (sid), this problem has been fixed in version 2.0116+dfsg-2. We recommend that you upgrade your libxml-libxml-perl packages.

Common Vulnerabilities and Exposures (CVE)