Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 3445-1 (pygments - security update)

Information

Severity

Severity

Critical

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

9.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

6 years ago

Modified

Modified

8 months ago

Summary

Javantea discovered that pygments, a generic syntax highlighter, is prone to a shell injection vulnerability allowing a remote attacker to execute arbitrary code via shell metacharacters in a font name.

Affected Software

Affected Software

pygments on Debian Linux

Detection Method

Detection Method

This check tests the installed software version using the apt package manager.

Solution

Solution

For the oldstable distribution (wheezy), this problem has been fixed in version 1.5+dfsg-1+deb7u1. For the stable distribution (jessie), this problem has been fixed in version 2.0.1+dfsg-1.1+deb8u1. For the testing distribution (stretch), this problem has been fixed in version 2.0.1+dfsg-2. For the unstable distribution (sid), this problem has been fixed in version 2.0.1+dfsg-2. We recommend that you upgrade your pygments packages.

Common Vulnerabilities and Exposures (CVE)