Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 361-1 (kdelibs)

Information

Severity

Severity

High

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

14 years ago

Modified

Modified

5 years ago

Summary

The remote host is missing an update to kdelibs announced via advisory DSA 361-1.

Insight

Insight

Two vulnerabilities were discovered in kdelibs: - - CVE-2003-0459: KDE Konqueror for KDE 3.1.2 and earlier does not remove authentication credentials from URLs of the 'user:password@host' form in the HTTP-Referer header, which could allow remote web sites to steal the credentials for pages that link to the sites. - - CVE-2003-0370: Konqueror Embedded and KDE 2.2.2 and earlier does not validate the Common Name (CN) field for X.509 Certificates, which could allow remote attackers to spoof certificates via a man-in-the-middle attack. These vulnerabilities are described in the following security advisories from KDE: http://www.kde.org/info/security/advisory-20030729-1.txt http://www.kde.org/info/security/advisory-20030602-1.txt For the current stable distribution (woody) these problems have been fixed in version 2.2.2-13.woody.8. For the unstable distribution (sid) these problems have been fixed in version 4:3.1.3-1. We recommend that you update your kdelibs package.

Solution

Solution

https://secure1.securityspace.com/smysecure/catid.html?in=DSA%20361-1

Common Vulnerabilities and Exposures (CVE)