Debian Security Advisory DSA 3841-1 (libxstream-java - security update)

Published: 2017-05-01 22:00:00
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:P

Solution Type:
Vendor Patch

Detection Type:
Linux Distribution Package

Affected Versions:
libxstream-java on Debian Linux

Recommendations:
For the stable distribution (jessie), this problem has been fixed in version 1.4.7-2+deb8u2. For the upcoming stable distribution (stretch), this problem will be fixed soon. For the unstable distribution (sid), this problem has been fixed in version 1.4.9-2. We recommend that you upgrade your libxstream-java Linux Distribution Packages.

Summary:
It was discovered that XStream, a Java library to serialise objects to XML and back again, was suspectible to denial of service during unmarshalling.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2017-7957

References:

http://www.debian.org/security/2017/dsa-3841.html

Search
Severity
Medium
CVSS Score
5.0

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.