Debian Security Advisory DSA 4138-1 (mbedtls - security update)

Published: 2018-03-14 23:00:00
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type:
Vendor Patch

Detection Type:
Linux Distribution Package

Affected Versions:
mbedtls on Debian Linux

Recommendations:
For the stable distribution (stretch), these problems have been fixed in version 2.4.2-1+deb9u2. We recommend that you upgrade your mbedtls Linux Distribution Packages. For the detailed security status of mbedtls please refer to its security tracker page linked in the references.

Summary:
Several vulnerabilities were discovered in mbed TLS, a lightweight crypto and SSL/TLS library, that allowed a remote attacker to either cause a denial-of-service by application crash, or execute arbitrary code.

Detection Method:
This check tests the installed software version using the apt Linux Distribution Package manager.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2017-18187
https://nvd.nist.gov/vuln/detail/CVE-2018-0487
https://nvd.nist.gov/vuln/detail/CVE-2018-0488

References:

https://www.debian.org/security/2018/dsa-4138.html
https://security-tracker.debian.org/tracker/mbedtls

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.