Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian Security Advisory DSA 748-1 (ruby1.8)

Information

Severity

Severity

High

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

14 years ago

Modified

Modified

5 years ago

Summary

The remote host is missing an update to ruby1.8 announced via advisory DSA 748-1.

Insight

Insight

A vulnerability has been discovered in ruby1.8 that could allow arbitrary command execution on a server running the ruby xmlrpc server. The old stable distribution (woody) did not include ruby1.8. This problem is fixed for the current stable distribution (sarge) in version 1.8.2-7sarge1. This problem is fixed for the unstable distribution in version 1.8.2-8. We recommend that you upgrade your ruby1.8 package.

Solution

Solution

https://secure1.securityspace.com/smysecure/catid.html?in=DSA%20748-1

Common Vulnerabilities and Exposures (CVE)