Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Debian: Security Advisory for webkit2gtk (DSA-5115-1)

Information

Severity

Severity

Medium

Family

Family

Debian Local Security Checks

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

3 months ago

Modified

Modified

3 months ago

Summary

The remote host is missing an update for the 'webkit2gtk' package(s) announced via the DSA-5115-1 advisory.

Insight

Insight

The following vulnerabilities have been discovered in the WebKitGTK web engine: CVE-2022-22624 Kirin discovered that processing maliciously crafted web content may lead to arbitrary code execution. CVE-2022-22628 Kirin discovered that Processing maliciously crafted web content may lead to arbitrary code execution. CVE-2022-22629 Jeonghoon Shin discovered that processing maliciously crafted web content may lead to arbitrary code execution.

Affected Software

Affected Software

'webkit2gtk' package(s) on Debian Linux.

Detection Method

Detection Method

Checks if a vulnerable package version is present on the target host.

Solution

Solution

For the oldstable distribution (buster), these problems have been fixed in version 2.36.0-3~deb10u1. For the stable distribution (bullseye), these problems have been fixed in version 2.36.0-3~deb11u1. We recommend that you upgrade your webkit2gtk packages.

Common Vulnerabilities and Exposures (CVE)