Dolphin Multiple Reflected Cross Site Scripting Vulnerabilities

Published: 2011-04-11 12:40:00

CVSS Base Vector:
AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact:
Successful exploitation will allow attackers to execute arbitrary script code in the browser of an unsuspecting user in the context of an affected site.

Affected Versions:
Dolphin version 7.0.4 Beta

Technical Details:
Multiple flaws are due to: - Input passed via the 'explain' parameter in 'explanation.php' script and 'relocate' parameter in '/modules/boonex/custom_rss/post_mod_crss.php' script is not properly sanitized before being returned to the user.

Recommendations:
No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Summary:
This host is running Dolphin and is prone to multiple reflected cross-site scripting vulnerabilities.

Solution Type:
Vendor will not fix

Detection Type:
remote_app

References:

http://packetstormsecurity.org/files/view/98408/Dolphin7.0.4-xss.txt

Search
Severity
Medium
CVSS Score
4.3

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.