Drupal Multiple Vulnerabilities02- May16 (Linux)

Published: 2016-05-18 10:47:47
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:M/Au:S/C:C/I:C/A:C

Detection Type:
Remote Banner Unreliable

Summary:
This host is running Drupal and is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Multiple flaws exixts due to, - An improper validation of JSON-encoded content in system module. - The XML-RPC system allows a large number of calls to the same method. - An error in 'user_save' function in User module.

Impact:
Successful exploitation will allow remote attackers to cause brute force attacks, to download and execute JSON-encoded content and also to gain elevated privileges.

Affected Versions:
Drupal 6.x before 6.38 and 7.x before 7.43 on Linux.

Recommendations:
Upgrade to version 6.38 or 7.43 or later.

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2016-3168
https://nvd.nist.gov/vuln/detail/CVE-2016-3163
https://nvd.nist.gov/vuln/detail/CVE-2016-3169

References:

https://www.drupal.org/SA-CORE-2016-001

Search
Severity
High
CVSS Score
8.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.