Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

FFmpeg <= 4.3 Buffer Overflow Vulnerability

Information

Severity

Severity

Critical

Family

Family

Buffer overflow

CVSSv2 Base

CVSSv2 Base

10.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

None Solution Available

Created

Created

2 years ago

Modified

Modified

2 years ago

Summary

FFmpeg is prone to a heap-based buffer overflow vulnerability.

Insight

Insight

The vulnerability exists in avio_get_str in libavformat/aviobuf.c because dnn_backend_native.c calls ff_dnn_load_model_native and a certain index check is omitted.

Affected Software

Affected Software

FFmpeg through version 4.3.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

No known solution is available as of 18th June, 2020. Information regarding this issue will be updated once solution details are available.

Common Vulnerabilities and Exposures (CVE)