HTTP File Server Remote Command Execution Vulnerability-02 Jan16

Published: 2016-01-11 09:52:37
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Summary:
This host is running HTTP File Server and is prone to remote command execution vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The flaw is due to an improper neutralization of Null byte or NUL character

Impact:
Successful exploitation will allow an attacker to execute arbitrary code by uploading a file with certain invalid UTF-8 byte sequences that are interpreted as executable macro symbols.

Detection Type:
Remote Banner

Affected Versions:
HttpFileServer version 2.3g and prior.

Recommendations:
No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Solution Type:
Vendor will not fix

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2014-6287

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/69782

References:

http://packetstormsecurity.com/files/128593
https://www.kb.cert.org/vuls/id/251276
https://www.exploit-db.com/exploits/39161/

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.