Huawei EulerOS: Security Advisory for libmirage (EulerOS-SA-2020-1090)

Published: 2020-01-23 13:20:03
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:L/AC:L/Au:N/C:C/I:C/A:C

Summary:
The remote host is missing an update for the Huawei EulerOS 'libmirage' Linux Distribution Package(s) announced via the EulerOS-SA-2020-1090 advisory.

Detection Method:
Checks if a vulnerable Linux Distribution Package version is present on the target host.

Technical Details:
libMirage 3.2.2 in CDemu has a NULL pointer dereference in the NRG parser in parser.c.(CVE-2019-15757) filters/filter-cso/filter-stream.c in the CSO filter in libMirage 3.2.2 in CDemu does not validate the part size, triggering a heap-based buffer overflow that can lead to root access by a local Linux user.(CVE-2019-15540)

Affected Versions:
'libmirage' Linux Distribution Package(s) on Huawei EulerOS Virtualization for ARM 64 3.0.5.0.

Recommendations:
Please install the updated Linux Distribution Package(s).

Solution Type:
Vendor Patch

Detection Type:
Linux Distribution Package

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-15540
https://nvd.nist.gov/vuln/detail/CVE-2019-15757

References:

https://developer.huaweicloud.com/ict/en/site-euleros/euleros/security-advisories/EulerOS-SA-2020-1090

Search
Severity
High
CVSS Score
7.2

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.