Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

IBM DB2 Multiple Denial of Service Vulnerabilities

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

8 years ago

Modified

Modified

3 years ago

Summary

This host is running IBM DB2 and is prone to multiple denial of service vulnerabilities.

Insight

Insight

The flaws are due to - An error during the handling of a specially crafted ALTER TABLE statement on an identity column. - An error when handling a specially crafted XML query, which can result in a consumption of CPU resources.

Affected Software

Affected Software

IBM DB2 versions 9.5 through FP10 IBM DB2 versions 9.7 through FP10 IBM DB2 versions 9.8 through FP5 IBM DB2 versions 10.1 through FP4 IBM DB2 versions 10.5 through FP4

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Apply the appropriate fix from the referenced advisory.

Common Vulnerabilities and Exposures (CVE)