Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

IBM DB2 REPEAT Buffer Overflow and TLS Renegotiation Vulnerabilities (Windows)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

12 years ago

Modified

Modified

3 years ago

Summary

The host is installed with IBM DB2 and is prone to buffer overflow and TLS Renegotiation vulnerabilities.

Insight

Insight

The flaws are due to: - Buffer overflow error within the scalar function 'REPEAT', which could allow malicious users to cause a vulnerable server to crash. - An error in the 'TLS' implementation while handling session 're-negotiations' which can be exploited to insert arbitrary plaintext into an existing TLS session via Man-in-the-Middle (MitM) attacks.

Affected Software

Affected Software

IBM DB2 version 9.1 prior to FP9

Solution

Solution

Update IBM DB2 9.1 FP9.

Common Vulnerabilities and Exposures (CVE)