Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

IBM WebSphere MQ Multiple Denial of Service Vulnerabilities - Mar17

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

6.8

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:N/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

5 years ago

Modified

Modified

4 years ago

Summary

This host is installed with IBM WebSphere MQ and is prone to multiple denial of service vulnerabilities.

Insight

Insight

Multiple flaws exist due to, - An administration command can cause IBM WebSphere MQ to access an invalid memory address, leading to a segmentation failure and causing the queue manager to become unresponsive. - An improper validation of invalid HTTP requests.

Affected Software

Affected Software

IBM WebSphere MQ version 8.0.0.0 through 8.0.0.5

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to IBM WebSphere MQ version 8.0.0.6 or later.

Common Vulnerabilities and Exposures (CVE)