Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

ImageMagick 7.0.7.28 multiple Vulnerabilities (Linux)

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

4.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

4 years ago

Modified

Modified

3 years ago

Summary

ImageMagick is prone to multiple vulnerabilities.

Insight

Insight

In ImageMagick 7.0.7.28, there is an infinite loop in the ReadOneMNGImage function of the coders/png.c file. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted mng file. In addition to that a memory leaks exist in 'WriteTIFFImage in coders/tiff.c' and 'ReadYCBCRImage in coders/ycbcr.c'.

Affected Software

Affected Software

ImageMagick version 7.0.7.28.

Detection Method

Detection Method

The script checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to ImageMagick version 7.0.7.31 or later.

Common Vulnerabilities and Exposures (CVE)