Vulnerability Details

Knot Resolver < 4.3.0 DoS Vulnerability

Published: 2019-12-18 03:30:41
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:P

Detection Type:
Executable Unreliable

Solution Type:
Vendor Patch

Summary:
Knot Resolver is prone to a denial of service vulnerability through high CPU utilization.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
DNS replies with very many resource records might be processed very inefficiently, in extreme cases taking even several CPU seconds for each such uncached message. For example, a few thousand A records can be squashed into one DNS message (limit is 64kB).

Affected Versions:
Knot Resolver prior to version 4.3.0.

Recommendations:
Update to version 4.3.0.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-19331

References:

https://www.knot-resolver.cz/2019-12-04-knot-resolver-4.3.0.html

Search
Severity
Medium
CVSS Score
5.0

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.