Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

MongoDB 3.6 < 3.6.20, 4.0 < 4.0.20, 4.2 < 4.2.9, 4.4 < 4.4.1 Read Overrun Vulnerability - Linux

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

6.8

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:C/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

MongoDB is prone to a read overrun vulnerability.

Insight

Insight

A user authorized to perform database queries may trigger a read overrun and access arbitrary memory by issuing specially crafted queries.

Affected Software

Affected Software

MongoDB versions 3.6 prior to 3.6.20, 4.0 prior to 4.0.20, 4.2 prior to 4.2.9 and 4.4 prior to 4.4.1.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 3.6.20, 4.0.20, 4.2.9, 4.4.1 or later.

Common Vulnerabilities and Exposures (CVE)