Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

MongoDB nativeHelper Denial of Service Vulnerability (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

6.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:S/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

6 years ago

Modified

Modified

3 years ago

Summary

This host is running MongoDB and is prone to a denial of service vulnerability.

Insight

Insight

An error exists in nativeHelper function in SpiderMonkey which fails to validate requests properly.

Affected Software

Affected Software

MongoDB version before 2.0.9 and 2.2.x before 2.2.4 on Linux

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to MongoDB version 2.0.9 or 2.2.4 or 2.4.2 or later.

Common Vulnerabilities and Exposures (CVE)