Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

MonkeyWeb POST with too much data

Information

Severity

Severity

High

Family

Family

Gain a shell remotely

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

16 years ago

Modified

Modified

3 years ago

Summary

The Monkey web server crashes when it receives a POST command with too much data. It *may* even be possible to make this web server execute arbitrary code with this attack.

Insight

Insight

The version of Monkey web server that is running is vulnerable to a buffer overflow on a POST command with too much data.

Solution

Solution

Upgrade to Monkey web server 0.6.2.

Common Vulnerabilities and Exposures (CVE)