Moodle 2.x / 3.x Remote Code Execution Vulnerability - Mar'17 (Windows)

Published: 2018-05-09 11:16:19
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
Moodle is prone to an authenticated remote code execution vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Remote Code Execution is made possible by a combination of - insufficiently restrictive administrator dashboard - PHP Object Injection Vulnerability - SQL Injection Vulnerability.

Impact:
Successful exploitation could allow an authenticated attacker to take complete control over the target system.

Affected Versions:
Moodle versions through 2.7.18, 2.8.0 through 3.0.8, 3.1.0 through 3.1.4 and 3.2.0 through 3.2.1.

Recommendations:
Update to version 2.7.19, 3.0.9, 3.1.5 or 3.2.2 respectively.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2017-2641

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/96977

References:

https://moodle.org/mod/forum/discuss.php?d=349419

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.