Moodle CMS <= 3.1.12, 3.2.x, 3.3.x <= 3.3.6, 3.4.x <= 3.4.3, 3.5.0 Multiple Vulnerabilities (Windows)

Published: 2018-07-12 08:10:32
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
Moodle CMS is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Following vulnerabilities exist: - It's possible for the core_course_get_categories web service to return hidden categories, which should be omitted when fetching course categories. - When a quiz question bank is imported, it is possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Affected Versions:
Moodle CMS through version 3.1.12, 3.2.0 through 3.3.6, 3.4.0 through 3.4.3 and 3.5.0.

Recommendations:
Update to version 3.1.13, 3.3.7, 3.4.4 or 3.5.1 respectively.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2018-10890
https://nvd.nist.gov/vuln/detail/CVE-2018-10891

References:

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10890
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10891

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.