Vulnerability Details

Mozilla Products 'jsinfer.cpp' Denial of Service Vulnerability (Windows)

Published: 2012-06-19 09:51:15
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact:
Successful exploitation could allow attackers to execute arbitrary code in the context of the browser or cause a denial of service.

Affected Versions:
Thunderbird ESR version 10.x before 10.0.5, Mozilla Firefox ESR version 10.x before 10.0.5 on Windows

Technical Details:
The 'jsinfer.cpp' function in ESR versions fails to determine data types, which allows to cause a denial of service via crafted JavaScript code.

Summary:
This host is installed with Mozilla firefox/thunderbird and is prone to denial of service vulnerability.

Recommendations:
Upgrade to Mozilla Firefox ESR version 10.0.5 or later, upgrade to Mozilla Thunderbird ESR version 10.0.5 or later.

Detection Type:
Windows Registry

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2012-1939

CVE Analysis

https://www.mageni.net/cve/CVE-2012-1939

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/53797

References:

http://secunia.com/advisories/49368
http://secunia.com/advisories/49366
http://securitytracker.com/id/1027120
http://www.mozilla.org/security/announce/2012/mfsa2012-34.html
http://www.mozilla.com/en-US/firefox/all.html
http://www.mozilla.org/en-US/thunderbird/

Severity
High
CVSS Score
9.3
Published
2012-06-19
Modified
2018-10-12
Category
Denial of Service

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.