Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

MySQL 'Gis_line_string::init_from_wkb()' DOS Vulnerability

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

4.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:S/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

11 years ago

Modified

Modified

3 years ago

Summary

The host is running MySQL and is prone to denial of service vulnerability.

Insight

Insight

The flaw is due to an error in 'Gis_line_string::init_from_wkb()' function in 'sql/spatial.cc', allows remote authenticated users to cause a denial of service by calling the PolyFromWKB function with WKB data containing a crafted number of line strings or line points.

Affected Software

Affected Software

MySQL version 5.1 before 5.1.51.

Solution

Solution

Upgrade to MySQL version 5.1.51.

Common Vulnerabilities and Exposures (CVE)