Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

MySQL Multiple Denial of Service Vulnerabilities

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

11 years ago

Modified

Modified

3 years ago

Summary

The host is running MySQL and is prone to multiple denial of service vulnerabilities.

Insight

Insight

The flaws are due to: - An error in propagating the type errors, which allows remote attackers to cause a denial of service via crafted arguments to extreme-value functions such as 'LEAST' or 'GREATEST'. - An unspecified error in vectors related to materializing a derived table that required a temporary table for grouping and user variable assignments. - An error in handling prepared statements that uses GROUP_CONCAT with the WITH ROLLUP modifier. - An error in handling a query that uses the GREATEST or LEAST function with a mixed list of numeric and LONGBLOB arguments.

Affected Software

Affected Software

MySQL 5.0 before 5.0.92, 5.1 before 5.1.51, and 5.5 before 5.5.6.

Solution

Solution

Upgrade to MySQL version 5.0.92, or 5.1.51 or 5.5.6.

Common Vulnerabilities and Exposures (CVE)