Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Novell eDirectory Multiple Stack Based Buffer Overflow Vulnerabilities

Information

Severity

Severity

High

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

10 years ago

Modified

Modified

4 years ago

Summary

This host is running Novell eDirectory and is prone to multiple multiple stack based buffer overflow vulnerabilities.

Insight

Insight

The flaws are due to improper validation of user-supplied input via a long HTTP Host header, which triggers an overflow in the BuildRedirectURL function.

Affected Software

Affected Software

Novell eDirectory 8.8.x to 8.8.1, and 8.x to 8.7.3.8 (8.7.3 SP8)

Solution

Solution

Upgrade to Novell eDirectory version 8.8.1 FTF1 or 8.7.3.9 (8.7.3 SP9)

Common Vulnerabilities and Exposures (CVE)