Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

OpenOffice rtl_allocateMemory Heap Based BOF Vulnerability

Information

Severity

Severity

Critical

Family

Family

Buffer overflow

CVSSv2 Base

CVSSv2 Base

9.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

14 years ago

Modified

Modified

3 years ago

Summary

The host has OpenOffice installed which is prone to heap based buffer overflow vulnerability.

Insight

Insight

The flaw is in alloc_global.c file in which rtl_allocateMemory function rounding up allocation requests to be aligned on a 8 byte boundary without checking the rounding results, in an integer overflow condition.

Affected Software

Affected Software

OpenOffice.org 2.x on Windows (Any).

Solution

Solution

Upgrade to OpenOffice 2.4.1 or later.

Common Vulnerabilities and Exposures (CVE)