Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

OpenSSL Denial Of Service Vulnerability (Windows)

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

4.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

6 years ago

Modified

Modified

3 years ago

Summary

This host is running OpenSSL and is prone to denial of service vulnerability.

Insight

Insight

The flaw is due to - A race condition flaw, leading to a double free error due to improper handling of pre-shared key (PSK) identify hints.

Affected Software

Affected Software

OpenSSL versions 1.0.0 before 1.0.0t, 1.0.1 before 1.0.1p, and 1.0.2 before 1.0.2d on Windows

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to OpenSSL 1.0.0t or 1.0.1p or 1.0.2d or later.

Common Vulnerabilities and Exposures (CVE)