Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

OpenSSL DoS Vulnerability (20150319 - 1) - Linux

Information

Severity

Severity

High

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

7.5

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

6 years ago

Modified

Modified

1 year ago

Summary

OpenSSL is prone to a denial of service (DoS) vulnerability.

Insight

Insight

A vulnerability existed in previous versions of OpenSSL related to the processing of base64 encoded data. Any code path that reads base64 data from an untrusted source could be affected (such as the PEM processing routines). Maliciously crafted base 64 data could trigger a segmenation fault or memory corruption.

Affected Software

Affected Software

OpenSSL version 0.9.8 through 0.9.8y, 1.0.0 through 1.0.0l and 1.0.1 through 1.0.1g.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Update to version 0.9.8za, 1.0.0m, 1.0.1h or later.

Common Vulnerabilities and Exposures (CVE)