PHP < 7.2.27, 7.3.x < 7.3.14, 7.4.x < 7.4.2 Multiple Vulnerabilities - Jan20 (Windows)

Published: 2020-01-24 06:12:06
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
PHP is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
PHP is prone to multiple vulnerabilities: - OOB read in php_strip_tags_ex (CVE-2020-7059) - Global buffer-overflow in 'mbfl_filt_conv_big5_wchar' (CVE-2020-7060)

Affected Versions:
PHP versions before 7.2.27, 7.3.x and 7.4.x.

Recommendations:
Update to version 7.2.27, 7.3.14, 7.4.2 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2020-7059
https://nvd.nist.gov/vuln/detail/CVE-2020-7060

References:

https://www.php.net/ChangeLog-7.php#7.2.27
https://www.php.net/ChangeLog-7.php#7.3.14
https://www.php.net/ChangeLog-7.php#7.4.2

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.