PHP Denial of Service Vulnerability - 03 - Jan17 (Linux)

Information

Severity

Severity

Medium

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:N/I:N/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

5 years ago

Modified

Modified

3 years ago

Summary

This host is installed with PHP and is prone to multiple denial of service vulnerabilities.

Insight

Insight

The flaw exists due to the php_wddx_pop_element function in ext/wddx/wddx.c via an inapplicable class name in a wddxPacket XML document, leading to mishandling in a wddx_deserialize call.

Affected Software

Affected Software

PHP versions 7.0.x before 7.0.15 and 7.1.x before 7.1.1.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PHP version 7.0.15, 7.1.1 or later.

Common Vulnerabilities and Exposures (CVE)

Ready to dive in? Start your free trial today.

Companies of all sizes—from startups to Fortune 500s—use Mageni to scan their assets for vulnerabilities, reduce risk exposure and minimizing the likelihood of a data breach. Free for 7-days then $39 USD Monthly. No Contracts, Cancel at Anytime and 7-days Money-Back Guarantee.

Get Started For Free
App screenshot