PHP Easy Download admin/save.php Parameter Code Injection Vulnerability

Published: 2008-10-24 21:33:44

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Summary:
The version of PHP Easy Download installed on the remote host fails to sanitize input to the 'moreinfo' parameter before using it in the 'save.php' script.

Impact:
By sending a specially-crafted value, an attacker can store and execute code at the privilege level of the remote web server.

Recommendations:
No known solution was made available for at least one year since the disclosure of this vulnerability. Likely none will be provided anymore. General solution options are to upgrade to a newer release, disable respective features, remove the product or replace the product by another one.

Solution Type:
Vendor will not fix

Detection Type:
Remote Vulnerability

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/21179

References:

http://www.milw0rm.com/exploits/2812

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.