phpMyAdmin < 4.9.4, 5.x < 5.0.1 SQL Injection Vulnerability - PMASA-2020-1 (Linux)

Published: 2020-01-13 05:25:37
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:S/C:P/I:P/A:P

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
phpMyAdmin is prone to an SQL injection vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
An SQL injection flaw has been discovered in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

Affected Versions:
phpMyAdmin prior to version 4.9.4 and 5.x prior to 5.0.1.

Recommendations:
Update to version 4.9.4, 5.0.1 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2020-5504

References:

https://www.phpmyadmin.net/security/PMASA-2020-1/

Search
Severity
Medium
CVSS Score
6.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.