Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

PostgreSQL < 7.3.19, 7.4.x < 7.4.17, 8.0.x < 8.0.13, 8.1.x < 8.1.9, and 8.2.x < 8.2.4 Untrusted Search Path Vulnerability (Linux)

Information

Severity

Severity

Medium

Family

Family

Databases

CVSSv2 Base

CVSSv2 Base

6.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:S/C:P/I:P/A:P

Solution Type

Solution Type

Vendor Patch

Created

Created

4 years ago

Modified

Modified

4 years ago

Summary

This host is running PostgreSQL and is prone to an untrusted search path vulnerability.

Insight

Insight

Untrusted search path vulnerability in PostgreSQL allows remote authenticated users, when permitted to call a SECURITY DEFINER function, to gain the privileges of the function owner, related to 'search_path settings'.

Affected Software

Affected Software

PostgreSQL versions before 7.3.19, 7.4.x before 7.4.17, 8.0.x before 8.0.13, 8.1.x before 8.1.9, and 8.2.x before 8.2.4 on Linux.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to PostgreSQL version 7.3.19, 7.4.17, 8.0.13, 8.1.9, or 8.2.4 respectively.

Common Vulnerabilities and Exposures (CVE)